Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Spell check not working in Open office or Libre office
09-12-2011, 04:06 AM
Post: #1
Spell check not working in Open office or Libre office
I occassionaly get a few emails asking solution to a very weird people where linux users normally Ubuntu linux users complain that their spell check does not work in Open office. The problem is the same in Libre office also which is basically just a renamed open office. Let's take a look at spell check problem.

"My Spell Checker in open office 3.0 doesn't work. It does not work on old or new documents at all. All I get is the spell checker is done and says every thing is fine and then it only gives the option to end it.
The auto spell checker works on new documents at the time they are being made. It does not highlight the misspelled words in red just like MS office which is very problematic as checking spelling as you type is what everyone expects while working on documents."

Solution to Spell checker not working in Open office
A quick solution to spell check problem is that openoffice only installs the spell checker for US and UK English. That basically means that only US and UK dictionaries are installed by default and if you set your default language settings to match UK or USA, you're spell checker will work just fine.

The problem will happen with any of the following english locales are set:

Australia
Canada
India
Jamaica
New Zealand
Philippines
South Africa
Namibia
Zimbabwe
Trinidad

You can fix it by using either USA english or UK english by:

Under OO writer go to -> tools -> options -> Language Settings -> Languages -> Default languages for documents -> western -> pick either english (UK) or english (USA) -> OK

Restart your open office and now try typing out incorrect words and you'll see the red marker highlighting the mistake. I am sure this is one of the main reasons most people's spell-checker including the staff in enterprises don't work in OpenOffice. Now you won't have to look up an alternate of open office or switch back to MS office because of the problem.
Visit this user's website Find all posts by this user
Quote this message in a reply
03-11-2012, 01:24 PM
Post: #2
RE: Spell check not working in Open office or Libre office
Thanks Aakash for the tip.

One additional point, for English (UK) on Ubuntu (or LinuxMint) you'll also need to make sure the package myspell-en-gb is installed.
[this is with LibreOffice 3.4.4, although I don't think the version is critical to this issue]
Find all posts by this user
Quote this message in a reply
10-02-2019, 07:12 PM
Post: #3
Spell check not working in Open office or Libre office
Сегодня настраивал сервак на Ubuntu и в процессе настройки вылезла ошибка Could not reliably determine the servers fully qualified domain name, using for ServerName , начал копаться в тырнете и короче где то на забугорном сайте нашел что я хосты не прописал.

Так вот, если у кого вдруг вылезет та же проблема, то для того чтобы ошибка исчезла нужно:

Внести имя сайта в список хостов сервера
Код:
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)